Flutter dependencies の書き方

f:id:MasayaStripes:20200309093356j:plain

パッケージを指定する為に必要な、dependenciesの記載について話します。

基本的なdependenciesの書き方

基本的な書き方は以下の通りです。

dependencies:
flutter:
sdk: flutter

cupertino_icons: ^0.1.2
english_words: ^3.1.5

デフォルトで書かれている、 cupertino_icons: ^0.1.2 を真似てもらえれば良いかと思います。

バージョンの指定

 特定のバージョンを指定する為には、"^3.1.5"といった数字を指定する必要があります。

cupertino_icons: ^0.1.2
english_words: ^3.1.5

指定しなかったら?

cupertino_icons: ^0.1.2
english_words:

english_words: の様に指定しなかった場合、最新のパッケージバージョンが取得されます。

 

以上です!